Back
Maintenance
Maintenance
[Scheduled] Data Center Maintenance
Completed 24 Oct at 02:30pm CEST.
Website
Web Server
Completed
Maintenance completed
Posted
24 Oct at 02:30pm CEST.
Started
On the 23rd of October, our hosting provider will perform a maintenance. Kindly note that interruptions can occur for approx. 180 minutes. We apologize for the inconvenience caused.
Posted
24 Oct at 12:00am CEST.