Get in touch
Back
Maintenance

Scheduled Maintenance - IsThisLegit (ITL)

Completed 11 Feb at 03:47pm CET.

IsThisLegit (Website)
Completed

The maintenance has concluded.

Posted 11 Feb at 03:47pm CET.
Updated

We have updated the maintenance timeframe as we are uploading files to the server.

Posted 11 Feb at 02:13pm CET.
Started

After a database failure on the 9th of February, we decided to plan scheduled maintenance for IsThisLegit (ITL). This maintenance will take some hours to complete as we will semi-manually add old data to our database. During this maintenance, IsThisLegit will not be available. We're sorry for the inconvenience.

Posted 11 Feb at 01:00pm CET.