Get in touch
Back
Maintenance

Database Failure

Completed 9 Feb at 12:44pm CET.

IsThisLegit (Website)
Completed

The database restore has been completed successfully. IsThisLegit should be working as per usual. Although, we are planning complete maintenance in the near future to eliminate the risk of having a database failure again.

Posted 9 Feb at 12:44pm CET.
Updated

We are restoring the database backup to attempt a recovery.

Posted 9 Feb at 12:17pm CET.
Started

IsThisLegit is currently down as we acknowledged a database failure. We're resolving the issue ASAP.

Posted 9 Feb at 11:40am CET.