Get in touch
Back
Maintenance

[Scheduled] Data Center Maintenance

Completed 19 Oct at 02:00am CEST.

Website Sandbox Web Server IsThisLegit HowToStake
Completed

Maintenance completed

Posted 19 Oct at 02:00am CEST.
Started

Our hosting provider will be performing a maintenance on our web server. Interruptions can occur during this time.

Posted 18 Oct at 12:01am CEST.