Get in touch
Back
Maintenance

Internal Server Error - IsThisLegit (Unscheduled)

Completed 27 Aug at 08:21pm CEST.

Website IsThisLegit HowToStake
Completed

The update was pushed successfully. The unscheduled maintenance has been completed.

Posted 27 Aug at 08:21pm CEST.
Updated

We have pushed an update and waiting for recovery.

Posted 27 Aug at 08:15pm CEST.
Started

One of our websites stopped responding to our pings and returned error 500 - Internal Server Error. This error kicked all websites hosted on the server offline. We're actively investigating this situation.

Posted 27 Aug at 07:58pm CEST.