Get in touch
Back
Maintenance

IsThisLegit Maintenance

Completed 9 Aug at 11:43pm CEST.

IsThisLegit
Completed

We have monitored the website for some time. The maintenance has now ended.

Posted 9 Aug at 11:43pm CEST.
Updated

The maintenance has concluded. We will now monitor it for some time.

Posted 9 Aug at 11:28pm CEST.
Updated

The maintenance will take a bit longer than expected.

ETA: 3 hours (+1 hour)

Posted 9 Aug at 10:33pm CEST.
Updated

The scheduled maintenance has started.

Posted 9 Aug at 09:00pm CEST.
Started

We've been working on an updated site for IsThisLegit.
We will be performing a server clean-up and bringing you a fresh and new website. This maintenance should help decrease load times for our visitors.
<b>Estimated time of the maintenance:</b> 2 hours.

Posted 9 Aug at 09:00pm CEST.